Jste zde

Iceweasel (Firefox) 3.5 v Debianu

Před pár dny jsem si nainstaloval Iceweasel 3.5.2 (sestavení Firefoxu pro Debian GNU/Linux)) z experimentální větve, protože v testing a unstable je stále pouze Iceweasel 3.0.12 (přitom 3.0.13 je venku už téměř měsíc a 3.5 dva měsíce) a ve stabilní větvi dokonce pouze Iceweasel 3.0.6... Když ale koukám na stav Firefoxu v jiných distribucích (v Ubuntu 9.04 je 3.0.8, v OpenSUSE 11.1 je 3.0.4, ve Fedoře 11 je 3.5.beta4), tak jsem rád za situaci, co je v Debianu (informace mám ze serveru distrowatch.com). Je mně jasné, že nových verzí balíčků z upstreamu je hodně, ale Iceweasel bude určitě patřit k těm nejpoužívanějším balíčkům, u kterých je oprava bezpečnostních chyb velice důležitá. No, ale třeba je za tím něco, o čem nevím, takže se v tom nebudu rýpat. V tomhle příspěvku bych chtěl zmínit moje dojmy z nové verze a problémy, na které jsem narazil (včetně jejich řešení).

Upgrade proběhl bez problému (upgradovalo to ještě libmozjs2d a xulrunner-1.9.1), aktualizace doplňků byla také bezproblémová (musel jsem pouze ručně upgradovat HTML Validator). Prohlížení webu také v pohodě (prohlížeč mně ani jednou nespadl). A teď k problémům.

  • Zbytečná ikona ve tvaru '+' pro vytvoření nového tabu. - Pokud otevíráte nové taby myší, pak proč ne, ale mě to akorát znervózňuje. Nepodařilo se mně tuto ikonu odstranit přes userChrome.css, tak jsem musel sáhnout po doplňku Remove New Tab Button, který to řeší.
  • Nelze ukončit poslední otevřený tab bez ukončení celého okna - Jelikož mám vždy otevřený alespoň jeden tab, u kterého jsem byl zvyklý na to, že když jej zavřu, tak mě zůstane akorát prázdný tab, ale Iceweasel se nezavře. Tohle se v Iceweaselu 3.5 změnilo. Fungujícím řešením byl (experimentální) doplněk Last Tab Close Button, který chování vrátil zase k normálu.
  • Přestalo fungovat přehrávání videí ve Flashi - Ano, flash je zlý a proprietární formát, zatěžuje mně klidně 90% CPU atd., ale bohužel se na webu rozšířil do té míry, že jeho podporu v prohlížeči potřebuji. Iceweasel mně začal hlásit LoadPlugin: failed to initialize shared library /usr/lib/iceweasel/plugins/libflashplayer.so [/usr/lib/iceweasel/plugins/libflashplayer.so: wrong ELF class: ELFCLASS32], což vypadalo na to, že se snaží použít binárku pro jinou architekturu, ale kromě upgradu Iceweaselu jsem s flashpluginem nic nedělal (v Konqueroru mně stále fungoval). Přinejmenším divné. Přeinstalování flashplayer-nonfree z repozitářů nepomohlo. Pomohlo až manuální stažení pluginu přímo ze stránek Adobe.

Možná si řeknete, že to jsou stupidní problémy, ale když jsem hledal řešení těchto problémů na webu tak jsem narazil na celou řadu uživatelů, které tyto změny také iritovaly. Prohlížeč prostě používáte každý den a na mnoho věcí si zvyknete. Už se pomalu přestávám divit mému spolubydlícímu z jeho obav ze SeaMonkey 2.0...

Na konec příspěvku si neodpustím ještě jednu poznámku. Všude se proklamuje, jak je nový Firefox rychlejší než jeho předchůdce, ba i dokonce, že je prostě ten nejrychlejší. Zajímalo by mě, proč prostě nepíšou na rovinu, že se jedná o rychlost implementace intepretu JavaScriptu. Aha, máte pravdu - marketing. O co mě ale jde - pokud nechám Iceweasel běžet 2-3 dny bez restartu, tak se stane práce s ním neúnosně pomalá. Reakce prohlížeče jsou zpomalené a když se podívám na využití paměti, tak mně htop ukazuje využití paměti až 25% (cca gigabajt). Dál něž 3 dny jsem to nikdy nevydržel a musel jsem Iceweasel restartovat. Tenhle problém se netýká pouze verze 3.5, ale i starších verzí. Nevím, zda je příčinou některý z mých používaným doplňků, nebo je to problém samotného Iceweaselu - na odzkoušení Iceweaselu bez doplňků jsem si zatím nenašel čas. Jelikož ostatní prohlížeče používám maximálně na testování výsledku renderování vytvořeného HTML/CSS kódu či kompatibility scriptů v JavaScriptu, tak nevím, jak je to s podobnou situací u nich. Máte někdo podobnou zkušenost, ať už s Firefoxem, nebo i s jiným prohlížečem?

Pokud jste již přešli na Firefox 3.5, vadilo vám také něco, nebo jste byli se vším spokojeni?

Komentáře

Verze balíčků na distrowatch jsou pravděpodobně takové, jaké byly v době vydání. V Ubuntu je v současné době Firefox 3.0.13 jak v 9.04, tak v 8.10. Že tam není 3.5.x je vcelku pochopitelné, v době vydání ještě nebyla stable. Aktualizace Firefoxu se v Ubuntu objevují v řádu hodin po vydání nové verze.

Jo, máš pravdu, teď se dívám, že se ta informace pro vydané verze distribucí neupdatuje. Díky za upřesnění. Při psaní jsem se mrknoul na výstup `apt-show-versions -a iceweasel` a sedělo to s tím, co je na distrowatch (včetně vydaného lennyho), tak jsem tomu nevěnoval pozornost. Holt je Debian nějak pozadu :).

Zajímavé je, že Iceweasel 3.0.14 se v Unstable objevil pár hodin po vydání Firefoxu 3.0.14, ale verzi 3.0.13 vynechali...

Přidat komentář